# Connection to AWS Aurora RDS failed Caused by: Read timed out

**URL:** <https://forum.liquibase.org/t/connection-to-aws-aurora-rds-failed-caused-by-read-timed-out/8848>\
**Category:** General Discussion\
**Created:** [November 28, 2023, 10:12pm UTC](https://forum.liquibase.org/t/connection-to-aws-aurora-rds-failed-caused-by-read-timed-out/8848 "2023-11-28T22:12:29Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![vschumacher](https://avatars.discourse-cdn.com/v4/letter/v/85f322/32.png) [@vschumacher](https://forum.liquibase.org/u/vschumacher)\
**Post date:** [November 28, 2023, 10:12pm UTC](https://forum.liquibase.org/t/connection-to-aws-aurora-rds-failed-caused-by-read-timed-out/8848/1 "2023-11-28T22:12:29Z")

</div>

I have a successful manual process for running Liquibase on EC2 and running change sets against AWS Aurora RDS (Postgres) and am working on automation. My issue is the first time I attempt to run a change on the RDS I receive the error shown below. If I go to the RDS and run a quick query and then retry to run a changeset from EC2 it runs no problem. I believe it is an issue with the RDS being serverless and needs to spin up due to a lack of traffic to the database prior to liquibase attempting to connect. My question: how can I get the connection to succeed with the first attempt to run a changeset? Some how modify the connection timeout settings to allow the RDS more time to spin up?

Error received: Unexpected error running Liquibase: Connection could not be created to jdbc:postgresql:(dbcluster) with driver org.postgresql.Driver. The connection attempt failed.

- Caused by: Read timed out

---

<div class="post-metadata">

**Author:** ![markmann](https://avatars.discourse-cdn.com/v4/letter/m/3be4f8/32.png) [@markmann](https://forum.liquibase.org/u/markmann)\
**Post date:** [December 5, 2023, 2:47pm UTC](https://forum.liquibase.org/t/connection-to-aws-aurora-rds-failed-caused-by-read-timed-out/8848/2 "2023-12-05T14:47:02Z")

</div>

Can you do the update using docker-compose? I know that gives you a depends-on option to see if another service is running. Admittedly I don’t know how you connect to an external database from within the docker compose file but might give you a heads up.

Here’s a forum post I did before with a docker-compose file I used to run liquibase against a DB Image, might be of some help - [Docker Liquibase image Certificates issue with SQL Server - #6 by markmann](https://forum.liquibase.org/t/docker-liquibase-image-certificates-issue-with-sql-server/8089/6)
