# Fails: MySQL -- generateChangeLog -- liquibase to PostgreSQL

**URL:** <https://forum.liquibase.org/t/fails-mysql-generatechangelog-liquibase-to-postgresql/1819>\
**Category:** General Discussion\
**Created:** [February 7, 2012, 12:12am UTC](https://forum.liquibase.org/t/fails-mysql-generatechangelog-liquibase-to-postgresql/1819 "2012-02-07T00:12:00Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Guest](https://avatars.discourse-cdn.com/v4/letter/g/8dc957/32.png) [@Guest](https://forum.liquibase.org/u/Guest)\
**Post date:** [February 7, 2012, 12:12am UTC](https://forum.liquibase.org/t/fails-mysql-generatechangelog-liquibase-to-postgresql/1819/1 "2012-02-07T00:12:00Z")

</div>

I use the liquibase command-line script with “generateChangeLog” to export a schema from MySQL to a change-log file.

I then try to use that to seed a database in PostgreSQ, again with the command-line script, now with “update”. It fails with:

&nbsp; &nbsp;ERROR: syntax error at or near “UNSIGNED”

I assumed that the change-log XML was database-agnostic as long as I stay away from elements. Is this not correct?

– Seth Oranje

…

…
