# I'm getting this error InvocationTargetException: liquibase/servicelocator/PackageScanClassResolver: liquibase.servicelocator.PackageScanClassResolver after update liquibase from 3.5.6 to 4.8.0

**URL:** <https://forum.liquibase.org/t/im-getting-this-error-invocationtargetexception-liquibase-servicelocator-packagescanclassresolver-liquibase-servicelocator-packagescanclassresolver-after-update-liquibase-from-3-5-6-to-4-8-0/7439>\
**Category:** General Discussion\
**Created:** [October 19, 2022, 8:21pm UTC](https://forum.liquibase.org/t/im-getting-this-error-invocationtargetexception-liquibase-servicelocator-packagescanclassresolver-liquibase-servicelocator-packagescanclassresolver-after-update-liquibase-from-3-5-6-to-4-8-0/7439 "2022-10-19T20:21:53Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![lucaslgr](https://avatars.discourse-cdn.com/v4/letter/l/dc4da7/32.png) [@lucaslgr](https://forum.liquibase.org/u/lucaslgr)\
**Post date:** [October 19, 2022, 8:21pm UTC](https://forum.liquibase.org/t/im-getting-this-error-invocationtargetexception-liquibase-servicelocator-packagescanclassresolver-liquibase-servicelocator-packagescanclassresolver-after-update-liquibase-from-3-5-6-to-4-8-0/7439/1 "2022-10-19T20:21:53Z")

</div>

I’m getting this error `InvocationTargetException: liquibase/servicelocator/PackageScanClassResolver: liquibase.servicelocator.PackageScanClassResolver` after update liquibase from 3.5.6 to 4.8.0.

My spring version is too old `1.4.0.RELEASE` and I think that could be related with that.  
Do you know if there is some way to solve this without updating my spring version?

Thanks in advance!

---

<div class="post-metadata">

**Author:** ![tabbyfoo](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.liquibase.org/tabbyfoo/32/748_2.png) [@tabbyfoo](https://forum.liquibase.org/u/tabbyfoo)\
**Post date:** [December 14, 2022, 6:22am UTC](https://forum.liquibase.org/t/im-getting-this-error-invocationtargetexception-liquibase-servicelocator-packagescanclassresolver-liquibase-servicelocator-packagescanclassresolver-after-update-liquibase-from-3-5-6-to-4-8-0/7439/2 "2022-12-14T06:22:13Z")

</div>

Since Spring Boot is currently in [version 3.0.0](https://github.com/spring-projects/spring-boot/wiki/Spring-Boot-3.0-Release-Notes) I think you’re probably going to need to update to at least [version 2.7](https://github.com/spring-projects/spring-boot/wiki/Spring-Boot-2.7-Release-Notes), as [version 1.4.0 has been out of support for at least 3-4 years](https://spring.io/projects/spring-boot#support) according to their site, and it’s generally not recommended to run EOL software for security reasons if nothing else.
