# Liquibase spanner migrations are failing to execute

**URL:** https://forum.liquibase.org/t/liquibase-spanner-migrations-are-failing-to-execute/9538
**Category:** General Discussion
**Created:** [July 12, 2024, 2:55pm UTC](https://forum.liquibase.org/t/liquibase-spanner-migrations-are-failing-to-execute/9538 "2024-07-12T14:55:19Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![jarchana](https://avatars.discourse-cdn.com/v4/letter/j/df705f/32.png) [@jarchana](https://forum.liquibase.org/u/jarchana)
#### Post date: [July 12, 2024, 2:55pm UTC](https://forum.liquibase.org/t/liquibase-spanner-migrations-are-failing-to-execute/9538/1 "2024-07-12T14:55:19Z")

</div>

The command im running

liquibase --changeLogFile /liquibase/lib/changelog.xml --defaults-file spannerliq.properties --url “jdbc:cloudspanner:/projects/projectid/instances/instancename/databases/dbname” --log-level debug update

errors i encounter are:

INFO [liquibase.database] Error getting default schema  
liquibase.exception.DatabaseException: Error executing SQL call current\_schema: Callable statements are not supported  
at liquibase.executor.jvm.JdbcExecutor.execute(JdbcExecutor.java:139)

Caused by: liquibase.exception.SetupException: Could not find directory, directory was empty, or no changelogs matched the provided search criteria for includeAll ‘/sql/tmp/spanner/projectid/instanceid/db/’

Here is my properties file

# cat spannerliq.properties

changelogFile=changelog.xml  
searchpath=/liquibase  
driver=com.google.cloud.spanner.jdbc.JdbcDriver  
classpath=/liquibase/liquibase-spanner-4.25.0-all.jar

#changelog.xml

\<?xml version="1.0" encoding="UTF-8"?\>

---

<div class="post-metadata">

### Author: ![mallod](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.liquibase.org/mallod/32/1191_2.png) [@mallod](https://forum.liquibase.org/u/mallod)
#### Post date: [July 25, 2024, 4:32pm UTC](https://forum.liquibase.org/t/liquibase-spanner-migrations-are-failing-to-execute/9538/2 "2024-07-25T16:32:41Z")

</div>

Hi @jarchana,

This error is because you are specifying a searchPath (`searchpath=/liquibase`), but the `includeAll` directory is is not a subdirectory of the specified in the `searchPath`. If your changelog file is under `/liquibase` directory try placing your `/sql/tmp/spanner/projectid/instanceid/db/` there as well.

Thanks,  
Daniel.
