# Liquibase status error - Redshift

**URL:** https://forum.liquibase.org/t/liquibase-status-error-redshift/8559
**Category:** Uncategorized
**Created:** [August 18, 2023, 4:46pm UTC](https://forum.liquibase.org/t/liquibase-status-error-redshift/8559 "2023-08-18T16:46:32Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![frankee](https://avatars.discourse-cdn.com/v4/letter/f/9de053/32.png) [@frankee](https://forum.liquibase.org/u/frankee)
#### Post date: [August 18, 2023, 4:46pm UTC](https://forum.liquibase.org/t/liquibase-status-error-redshift/8559/1 "2023-08-18T16:46:32Z")

</div>

First time configuration for Liquibase Redshift  
Attempting to issue ‘liquibase status’ I encounter the below error.

Summary of the liquibase.properties file:# Type of database  
driver: com.amazon.redshift.jdbc.Driver

# conn details

url: yyy  
username: yyy  
password: yyy

# liquibase details

classpath: redshift-jdbc42-2.1.0.14.jar  
changeLogFile=rsDbPermissionsChangelog.sql

Actual error:  
####################################################

## \_ \_ \_ \_

## | | (_) (_) |

## | | \_ \_\_ \_ \_ \_ _| |_\_ \_\_ \_ \_\_\_ \_\_\_

## | | | |/ \_` | | | | | '_ \ / _` / \_\_|/ \_ \

## | |_| | (| | || | | |_) | (_| \__ \ \_\_/

## \ __/|\_, |\_,_|_|_. **/ \__ ,_|** _/\__\_|

## | |

## |\_|

## 

## Get documentation at [docs.liquibase.com](http://docs.liquibase.com)

## Get certified courses at [learn.liquibase.com](http://learn.liquibase.com)

## 

####################################################  
Starting Liquibase at 17:35:52 (version 4.23.1 #12042 built at 2023-08-10 13:48+0000)  
Liquibase Version: 4.23.1  
Liquibase Open Source 4.23.1 by Liquibase

Unexpected error running Liquibase: ERROR: current transaction is aborted, commands ignored until end of transaction block

- Caused by: ERROR: syntax error at end of input  
Position: 20

The command is a simple create role, and works from dbeaver / command line.  
Also to add I have the following jar files in the liquibase lib directory:  
liquibase-redshift-4.22.0  
redshift-jdbc42-2.1.0.14

The changelog file is a .sql file issuing a create role xxx; command

Any advice / suggestions very welcome.

---

<div class="post-metadata">

### Author: ![frankee](https://avatars.discourse-cdn.com/v4/letter/f/9de053/32.png) [@frankee](https://forum.liquibase.org/u/frankee)
#### Post date: [August 21, 2023, 12:35pm UTC](https://forum.liquibase.org/t/liquibase-status-error-redshift/8559/2 "2023-08-21T12:35:09Z")

</div>

As an update I fixed.  
I needed to copy the following:  
liquibase-redshift-4.22.0  
redshift-jdbc42-2.1.0.14

to the correct lib folder, this I had failed to do. i.e. I had copied to another lib directory  
C:\Program Files\liquibase\liquibase-4.23.1\lib
