# Liquibase update command fail on Redshift

**URL:** <https://forum.liquibase.org/t/liquibase-update-command-fail-on-redshift/8238>\
**Category:** General Discussion\
**Created:** [May 16, 2023, 9:05pm UTC](https://forum.liquibase.org/t/liquibase-update-command-fail-on-redshift/8238 "2023-05-16T21:05:55Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ricto](https://avatars.discourse-cdn.com/v4/letter/r/bc79bd/32.png) [@Ricto](https://forum.liquibase.org/u/Ricto)\
**Post date:** [May 16, 2023, 9:05pm UTC](https://forum.liquibase.org/t/liquibase-update-command-fail-on-redshift/8238/1 "2023-05-16T21:05:55Z")

</div>

Hi guys,  
I’m very new to Liquibase and trying to use Liquibase to create and maintain schema on Redshift.  
I downloaded and installed latest Liquibase package (v4.22.0) to my Mac. Downloaded redshift-jdbc42-2.1.0.14.jar and specified the correct class path in the liquibase.properties.

```auto
# Type of database
driver: com.amazon.redshift.jdbc.Driver

# Connection details
url: xxx
username: xxx
password: xxx

# Liquibase details
changeLogFile: changelog.xml
classpath: redshift-jdbc42-2.1.0.14.jar

```

However when running ‘liquibase update’ command, I got the following error.

```auto
Unexpected error running Liquibase: ERROR: current transaction is aborted, commands ignored until end of transaction block [Failed SQL: (0) CREATE TABLE DATABASECHANGELOGLOCK (ID INT NOT NULL, LOCKED BOOLEAN NOT NULL, LOCKGRANTED datetime, LOCKEDBY VARCHAR(255), CONSTRAINT PK_DATABASECHANGELOGLOCK PRIMARY KEY (ID))]
  - Caused by: ERROR: syntax error at end of input
  Position: 20

```

I ran this SQL command directly in my Redshift QueryEditor console and it was successful. I’m not sure why it complained about syntax error.

Does anyone has clues on what might cause this and know how to resolve it?  
Thanks in advance!

Richard

---

<div class="post-metadata">

**Author:** ![PJatLiquibase](https://avatars.discourse-cdn.com/v4/letter/p/d26b3c/32.png) [@PJatLiquibase](https://forum.liquibase.org/u/PJatLiquibase)\
**Post date:** [May 17, 2023, 6:53pm UTC](https://forum.liquibase.org/t/liquibase-update-command-fail-on-redshift/8238/2 "2023-05-17T18:53:20Z")

</div>

Hi @Ricto,

Are you using the liquibase-redshift extension? You can see more details here: [Using Liquibase with AWS Redshift](https://docs.liquibase.com/start/tutorials/aws-redshift.html)

`-PJ`

---

<div class="post-metadata">

**Author:** ![Ricto](https://avatars.discourse-cdn.com/v4/letter/r/bc79bd/32.png) [@Ricto](https://forum.liquibase.org/u/Ricto)\
**Post date:** [May 17, 2023, 9:20pm UTC](https://forum.liquibase.org/t/liquibase-update-command-fail-on-redshift/8238/3 "2023-05-17T21:20:20Z")

</div>

Thanks PJ! The issue is resolved by copying liquibase-redshift-4.22.0.jar to the `liquibase/lib` directory.
