# Unable to execute liquibase update on the new mssql dsetup

**URL:** <https://forum.liquibase.org/t/unable-to-execute-liquibase-update-on-the-new-mssql-dsetup/7466>\
**Category:** Liquibase Development\
**Created:** [October 26, 2022, 10:28pm UTC](https://forum.liquibase.org/t/unable-to-execute-liquibase-update-on-the-new-mssql-dsetup/7466 "2022-10-26T22:28:36Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![rajxraj](https://avatars.discourse-cdn.com/v4/letter/r/85f322/32.png) [@rajxraj](https://forum.liquibase.org/u/rajxraj)\
**Post date:** [October 26, 2022, 10:28pm UTC](https://forum.liquibase.org/t/unable-to-execute-liquibase-update-on-the-new-mssql-dsetup/7466/1 "2022-10-26T22:28:36Z")

</div>

Getting following error… What could be the issue? I did setup the liquibase.properties file with right DB URL, Username and Password.

Starting Liquibase at 14:10:52 (version 4.17.1 #5120 built at 2022-10-21 13:42+0000)

Liquibase Version: 4.17.1

Liquibase Community 4.17.1 by Liquibase

Unexpected error running Liquibase: Connection could not be created to jdbc:sqlserver://localhost:1433;databaseName=master; with driver com.microsoft.sqlserver.jdbc.SQLServerDriver. The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: “PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target”. ClientConnectionId:d1f7fb68-0f88-45ed-ba4e-9a7f9a95fadc

---

<div class="post-metadata">

**Author:** ![rajxraj](https://avatars.discourse-cdn.com/v4/letter/r/85f322/32.png) [@rajxraj](https://forum.liquibase.org/u/rajxraj)\
**Post date:** [October 26, 2022, 10:36pm UTC](https://forum.liquibase.org/t/unable-to-execute-liquibase-update-on-the-new-mssql-dsetup/7466/2 "2022-10-26T22:36:47Z")

</div>

It is resolved. I changed the URL to following in liquibase.properties

url=jdbc:sqlserver://localhost:1433;databaseName=master;integratedSecurity=false;encrypt=true;trustServerCertificate=true
