# Unexpected error ... '/liquibase/C' does not exist

**URL:** https://forum.liquibase.org/t/unexpected-error-liquibase-c-does-not-exist/5197
**Category:** General Discussion
**Created:** [March 15, 2021, 3:30pm UTC](https://forum.liquibase.org/t/unexpected-error-liquibase-c-does-not-exist/5197 "2021-03-15T15:30:13Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![mohsink](https://avatars.discourse-cdn.com/v4/letter/m/3da27b/32.png) [@mohsink](https://forum.liquibase.org/u/mohsink)
#### Post date: [March 15, 2021, 3:30pm UTC](https://forum.liquibase.org/t/unexpected-error-liquibase-c-does-not-exist/5197/1 "2021-03-15T15:30:13Z")

</div>

I run below after navigating to C:\app\xiamb\product\liquibase\>  
I have a directory changelog under the above directory which has the liquibase property file.

Command line with run with administrator on powershell :

docker run --rm -v C:\app\xiamb\product\liquibase:\liquibase\changelog liquibase/liquibase --classpath=C:\app\xiamb\product\liquibase\lib\ojdbc8.jar --url=jdbc:oracle:thin:@0.0.0.0:1521/XEPDB1 --changeLogFile=changelog/sample.changelog.xml update

Error message :  
Unexpected error running Liquibase: ‘/liquibase/C’ does not exist

Environment : Windows 10 running docker

What am I missing or doing incorrectly ?

thank you

---

<div class="post-metadata">

### Author: ![ronak](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.liquibase.org/ronak/32/221_2.png) [@ronak](https://forum.liquibase.org/u/ronak)
#### Post date: [March 26, 2021, 4:16pm UTC](https://forum.liquibase.org/t/unexpected-error-liquibase-c-does-not-exist/5197/2 "2021-03-26T16:16:43Z")

</div>

Hi @mohsink ,

I am basing my response off of this [how-to article](https://www.liquibase.org/blog/using-liquibase-via-docker). perhaps you are missing the front / before changelog in your --changeLogFile argument?

> [@mohsink](#):
>
> –changeLogFile=changelog/sample.changelog.xml update

Maybe should be:  
–changeLogFile=/changelog/sample.changelog.xml update

---

<div class="post-metadata">

### Author: ![hotfix](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.liquibase.org/hotfix/32/1295_2.png) [@hotfix](https://forum.liquibase.org/u/hotfix)
#### Post date: [February 21, 2024, 11:56am UTC](https://forum.liquibase.org/t/unexpected-error-liquibase-c-does-not-exist/5197/3 "2024-02-21T11:56:24Z")

</div>

I also ran into this issue.

Check if you are using Windows style paths, the Docker container is running on a Linux system and will not be able to resolve the path.

I am instantiating the Docker container with the `--defaultsFile` option to point to a `liquibase.properties` file.

In my properties file, I was using a Windows style path:

```auto
# liquibase.properties
classpath: C:\Git\my_project\ojdbc8.jar

```

However, that resulted in:

> Error parsing command line: /liquibase/"C does not exist

When I removed it, the issue was resolved.

Apparently, the ojdvbc8.jar is already included in the Docker image.
