# Update-to-tag missing strict parameter

**URL:** <https://forum.liquibase.org/t/update-to-tag-missing-strict-parameter/10870>\
**Category:** General Discussion\
**Created:** [May 19, 2026, 11:31am UTC](https://forum.liquibase.org/t/update-to-tag-missing-strict-parameter/10870 "2026-05-19T11:31:09Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![4ndr345](https://avatars.discourse-cdn.com/v4/letter/4/b2d939/32.png) [@4ndr345](https://forum.liquibase.org/u/4ndr345)\
**Post date:** [May 19, 2026, 11:31am UTC](https://forum.liquibase.org/t/update-to-tag-missing-strict-parameter/10870/1 "2026-05-19T11:31:09Z")

</div>

The documentation for the `update-to-tag` command mentions the `strict` option, but using it results in an error.

> In Liquibase 4.30.0 and later, you can set the `--strict` parameter to `true` to ensure that Liquibase requires you to specify a valid tag before running the command.

> **[update-to-tag - Liquibase](https://docs.liquibase.com/community/reference-guide-5-0-2/init-update-and-rollback-commands/update-to-tag)**

```bash
liquibase.bat --defaultsFile=liquibase-dev.properties update-to-tag --context-filter=dev --strict=true --tag=“2026.05.12.090100”
Unexpected argument(s): --strict=true

For detailed help, try ‘liquibase --help’ or ‘liquibase --help’

```

The help section doesn’t mention this option .

Is this a mistake in the documentation, am I missing something, or is it a bug?

Thank you very much,  
Andreas

p.s. Version

_Starting Liquibase at 13:28:05 using Java 21.0.7 (version 5.0.2 #10172 built at 2026-03-04 00:27+0000)  
Liquibase Version: 5.0.2_

---

<div class="post-metadata">

**Author:** ![4ndr345](https://avatars.discourse-cdn.com/v4/letter/4/b2d939/32.png) [@4ndr345](https://forum.liquibase.org/u/4ndr345)\
**Post date:** [May 20, 2026, 6:49am UTC](https://forum.liquibase.org/t/update-to-tag-missing-strict-parameter/10870/2 "2026-05-20T06:49:22Z")

</div>

It’s really embarrassing, but I found my mistake—it’s a global parameter. When I set it now, I get the following error:

```bash
liquibase.bat --defaultsFile=liquibase-dev.properties status --context-filter=dev --verbose=true
Starting Liquibase at 08:44:42 using Java 21.0.7 (version 5.0.2 #10172 built at 2026-03-04 00:27+0000)
Liquibase Version: 5.0.2

Error parsing command line: Strict check failed due to undefined key(s) for ‘status’ command in file exists at path liquibase-dev.properties’:

‘liquibase.command.dbms’

‘liquibase.command.update.showSummary’
To define keys that could apply to any command, prefix it with ‘liquibase.command.’
To disable strict checking, remove ‘strict’ from the file.

For detailed help, try ‘liquibase --help’ or ‘liquibase --help’
Logs saved to log/logliquibase.log

```

Both options are enabled

`findstr /n /i /c:“liquibase.command.dbms” liquibase-dev.properties`  
`28:liquibase.command.dbms: oracle`  
`findstr /n /i /c:“liquibase.command.update.showSummary” liquibase-dev.properties`  
`67:liquibase.command.update.showSummary: VERBOSE`

So what’s the problem now?

thanks

andreas

---

<div class="post-metadata">

**Author:** ![4ndr345](https://avatars.discourse-cdn.com/v4/letter/4/b2d939/32.png) [@4ndr345](https://forum.liquibase.org/u/4ndr345)\
**Post date:** [May 20, 2026, 11:20am UTC](https://forum.liquibase.org/t/update-to-tag-missing-strict-parameter/10870/3 "2026-05-20T11:20:38Z")

</div>

Removing the parameters from the properties file was the solution.
