# Upgrading Liquibase version from 4.5.0 to 4.23.1

**URL:** <https://forum.liquibase.org/t/upgrading-liquibase-version-from-4-5-0-to-4-23-1/8699>\
**Category:** General Discussion\
**Created:** [September 26, 2023, 10:04pm UTC](https://forum.liquibase.org/t/upgrading-liquibase-version-from-4-5-0-to-4-23-1/8699 "2023-09-26T22:04:34Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ponnatd](https://avatars.discourse-cdn.com/v4/letter/p/ad7895/32.png) [@ponnatd](https://forum.liquibase.org/u/ponnatd)\
**Post date:** [September 26, 2023, 10:04pm UTC](https://forum.liquibase.org/t/upgrading-liquibase-version-from-4-5-0-to-4-23-1/8699/1 "2023-09-26T22:04:34Z")

</div>

Does anyone face this error when updating the liquibase version to 4.23.1 from 4.5.0?  
My spring-boot version is pointed to 3.1.2 and I am using databasechangelog.yaml file as config for liquibase

Caused by: liquibase.exception.DatabaseException: liquibase.exception.DatabaseException: ERROR: cannot update table “databasechangelog” because it does not have a replica identity and publishes updates  
Hint: To enable updating the table, set REPLICA IDENTITY using ALTER TABLE. [Failed SQL: (0) UPDATE {schemaName}.databasechangelog SET MD5SUM = NULL]

---

<div class="post-metadata">

**Author:** ![filipelautert](https://avatars.discourse-cdn.com/v4/letter/f/dfb087/32.png) [@filipelautert](https://forum.liquibase.org/u/filipelautert)\
**Post date:** [November 7, 2023, 12:39pm UTC](https://forum.liquibase.org/t/upgrading-liquibase-version-from-4-5-0-to-4-23-1/8699/2 "2023-11-07T12:39:44Z")

</div>

Hello @ponnatd ! Seems this error is not related to liquibase but it is a Postgresql configuration ([PostgreSQL: Documentation: 12: 30.1.&nbsp;Publication](https://www.postgresql.org/docs/12/logical-replication-publication.html)) . The easier solution would be to run the following sql:

```auto
ALTER TABLE databasechangelog REPLICA IDENTITY FULL;

```
