Cannot Deregister ChangeLog in Hub

Trying to “unregister” a change log from the hub… I’m only CLI version 4.4… running this command:

liquibase --defaultsFile --liquibase-hub-api-key={hidden} deactivateChangeLog --changelog-file=dbChangeLog.xml

And I am receiving this error:

Unexpected error running Liquibase: Error parsing line 2 column 315 of dbChangeLog.xml: cvc-complex-type.3.2.2: Attribute ‘changeLogId’ is not allowed to appear in element ‘databaseChangeLog’.

I am certainly vexed… what can I do?

Hi @ismail44

Could you paste the exact contents of your dbChangeLog file?

From the error message it seems to be an issue where databaseChangeLog is referring to some other versions of the xml namespaces and schema, when they should have been referring to 4.4.

Maybe this could help.

Rakhi Agrawal

Hi… thanks for the reply… here are the pertinent lines:

<?xml version="1.0" encoding="utf-8"?>
<databaseChangeLog xmlns="" xmlns:xsi="" xsi:schemaLocation="" changeLogId="7135e990-6ecd-4524-89ca-a40a77fb8d07">

I upgraded my CLI AFTER our changelog stuff had been done… so… maybe I need to update that?

Thank you so much… I updated my version in the XML and it worked PERFECTLY!!! I didn’t even consider that as the case!

Glad it worked!

Rakhi Agrawal