Current date in column insert

I’m a newby enthousiast liquibase user and I have a little question that may be a problem.

I’m using liquibase 2.0.4 on an Oracle database and I try to insert some data with a date column. I want this date column to have the current date value.

I tried to use this syntax:


which seem legit to me but I have a stange error message, like if the generated sql was incorrect: (sorry the error is in french)

  1. SEVERE 24/07/12 11:43:liquibase: Change Set changelog/6.5/changelog.xml::6.5-1::nremy failed.  Error: java.sql.SQLException: Paramètre IN ou OUT absent dans l’index :: 9
    liquibase.exception.DatabaseException: java.sql.SQLException: Paramètre IN ou OUT absent dans l’index :: 9
            at liquibase.change.core.InsertDataChange$ExecutableStatement.execute(
            at liquibase.executor.jvm.JdbcExecutor.execute(
            at liquibase.database.AbstractDatabase.execute(
            at liquibase.database.AbstractDatabase.executeStatements(
            at liquibase.changelog.ChangeSet.execute(
            at liquibase.changelog.visitor.UpdateVisitor.visit(
            at liquibase.Liquibase.update(
            at liquibase.Liquibase.updateTestingRollback(
            at liquibase.integration.commandline.Main.doMigration(
            at liquibase.integration.commandline.Main.main(
    Caused by: java.sql.SQLException: ParamÞtre IN ou OUT absent dans l’index :: 9
            at oracle.jdbc.driver.DatabaseError.throwSqlException(
            at oracle.jdbc.driver.DatabaseError.throwSqlException(
            at oracle.jdbc.driver.OraclePreparedStatement.processCompletedBindRow(
            at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(
            at oracle.jdbc.driver.OraclePreparedStatement.execute(
            at liquibase.change.core.InsertDataChange$ExecutableStatement.execute(
            … 10 more

I tried using the fixed date syntax and it works like a charm:

I didn’t found many information on correctly using sysdate with liquibase, do you have some more information do point me in the right direction ?

Thanks in advance.

I found out it was a bug in 2.0.4, it’s working in 2.0.3 and 2.0.5.

Too bad I suffer from another bug in 2.0.5 CORE-1170

I’ll stick with liquibase 2.0.3 for now ;o)