dropAllForeignKeyConstraints no longer works

On Oracle, liquibase 3.6.3 seems to run a for a long time.

Looking at the logs, it seems to be running a LOT of SQL, but it never finds or removes any foreign keys for me.

I tried liquibase 3.5.4 and the exact same change log file works fine (and runs a LOT faster, too).

Can anyone else confirm this as a bug?   I briefly tried to search for this and report it in the Issue Tracker, but it said I didn’t have the permissions to do so

If you have a small reproducible test case, I can certainly file a bug for you. 

Steve Donie
Principal Software Engineer
Datical, Inc. http://www.datical.com/

This file recreates the issue in liquibase 3.6.3, but works in 3.5.5.

After you run update against the file, run the Oracle SQL: “select * from all_constraints where table_name = ‘TESTA’”       If there are any rows, the test has failed.

Not sure if this occurs on other DB’s or just Oracle.

Compare the performance, too.  It’s orders of magnitude slower