Error in running Liquibase migration script

Hello All,

I have started implementing the Liquibase migration script for R3 Corda (Postgres DB). I am using the XML format of the scripts.

I have 2 version of script.
v1 - creation of the table.
v2 addition of the indexes on table created.

While doing that I am getting the below error - I have also tried this after resetting the DB, but still the error is same.

6:12.485 [main] INFO databaseInitialisation - DatabaseInitialisation(id="6inuWBYT";changeset="migration/table-name.changelog-v2.xml::add_indexes_table-name::NodeOperator";source="dev.jar";status="start")
2021-06-30 10:46:12.486
05:16:12.485 [main] ERROR liquibase.changelog.ChangeSet - Change Set migration/table-name.changelog-v2.xml::add_indexes_table-name::NodeOperator failed. Error: null
2021-06-30 10:46:12.491
05:16:12.490 [main] ERROR databaseInitialisation - DatabaseInitialisation(id="6inuWBYT";changeset="migration/table-name.changelog-v2.xml::add_indexes_table-name::NodeOperator";source="dev.jar";status="error";error_code="999";message="Migration failed for change set migration/table-name.changelog-v2.xml::add_indexes_table-name::NodeOperator: Reason: java.lang.NullPointerException")

But when I merged these 2 version of script in one script and deploy it (after resetting the DB). It worked fine.

Can anyone please suggest.


We’ll need to see the contents of the 2 xml files. Can you paste them here?

Hello @aktjain

Could you please share following details to help you with the issue:

  1. Liquibase version you are using
  2. file (to chekc the configuration)
  3. The exact changeset/changelogs file you have used when you got this error

Rakhi Agrawal