generateChangeLog generates XML header only

Hi all.

Liquibase (3.6.3) newbie with Informix (12.10.FC9DE on a Mac) here.

Liquibase seems to connect fine but only generates the XML “header” part of the change log:

mac02822:lb-trial wwheeler$ liquibase --url=“jdbc:informix-sqli:INFORMIXSERVER=informix01_tcp;SQLH_TYPE=FILE;SQLH_FILE=/opt/informix/informix/etc/sqlhosts;DATABASE=test1” --logLevel=debug --classpath=/opt/informix/informix/jdbc/lib/ifxjdbc.jar --changeLogFile ./test1ChangeLog.xml generateChangeLog

Starting Liquibase at Thu, 07 Mar 2019 09:10:57 GMT (version 3.6.3 built at 2019-01-29 11:34:48)

Liquibase command ‘generateChangeLog’ was executed successfully.

mac02822:lb-trial wwheeler$ cat test1ChangeLog.xml

<?xml version="1.1" encoding="UTF-8" standalone="no"?>"/>

Also, I tried to use diffChangeLog against an empty database and got the same result. Any ideas?

Solved my own problem, kind of: gave me the clue.

I added --defaultSchemaName informix (as, in this case, all my objects were created by this user.)

However, this leads to another problem. In my production environment, I can’t guarantee that all existing objects will be created by one user, also it’s quite conceivable that even if I find them all today, someone else could add an object with the wrong “owner” in future and I wouldn’t know and neither would liquibase.

Is there some shorthand form for “get me all schemas”?