Is splitStatements still supported in custom SQL?

Hello folks,

We have a problem with the trunk version of liquibase. Some of our multi-statement custom sql (which worked on a previous version of liquibase) is now failing because it is being split on semi-colons, even though we haven’t specified the ‘splitStatements=“true”’; it even continues to fail when we specify that ‘splitStatements=“false”’. I think I’ve tracked this down to the following changeset on liquibase.change.AbstractSQLChange:

Note that the test on isSplittingStatements() was removed in this revision, so that sql statements are always split now. I’ve patched our version locally (patch is attached) and this works now. Is the intention that splitStatements is still supported?


Have just noticed that the patch attached to the previous message was generated against an old revision of the trunk and fails when applied to the head of trunk. Here is patch which should work with the head of trunk.

I applied your patch.  Thanks a lot!