Max length for executeCommand arg value.

I’m trying to use the executeCommand statement.  I’m noticing that if the value in the arg statement is over about 32 characters, then liquibase locks up while executing.  I first noticed this behavior using 1.8.0, but confirmed that its occurring in 1.9.3.

To help troubleshoot.  I’m hitting a batch file that will echo out the parameters passed in.

Here’s the line from the command window

Jun 3, 2009 4:17:28 PM liquibase.database.template.JdbcTemplate comment
INFO: Lock Database
Jun 3, 2009 4:17:28 PM liquibase.lock.LockHandler acquireLock
INFO: Successfully acquired change log lock
Jun 3, 2009 4:17:29 PM liquibase.database.AbstractDatabase getRanChangeSetList
Jun 3, 2009 4:17:30 PM liquibase.database.template.JdbcTemplate comment
INFO: ChangesetXXX.xml::100::username::(MD5Sum: 1234567890abcef1234567890abcdef)

The output just stops there.

I’m running Java version 1.6.0_11.  Has anyone else seen similar behavior?


– Erin

I haven’t seen it, but I haven’t tried a long arg value.  It is using java.lang.ProcessBuilder, but I don’t see any problems with the code off hand.  I’ll have to debug it to find out more.  If you run liquibase with --logLevel=FINEST do you get anything more useful?


Hi –

I had “logLevel: Finest” in my default properties file.  I tried overriding this and setting it at the command line, but did not see the output change.  I tried using --logLevel=info as well, and the output remains the same.


– Erin