NullPointerException executing a diff-database in 2.0RC1

Liquibase gives a NullPointerException at liquibase.database.typeconversion.core.AbstractTypeConverter.getDataType ( I try to execute a diffDatabase where there are changes in datatypes from columns in the db (and new tables and relations).
The 2.0RC1 generateChangeLog ant task works perfectly with the same hibernate files, generating all datatypes.
The 1.9.4 diffDatabaseToChangeLog ant task works “perfectly” with the same hibernate files, generating changes without taking into account of datatype changes.

    [diffDatabaseToChangeLog] INFO 5/11/09 10:33:liquibase: Could not set remarks reporting on OracleDatabase: liquibase.database.JdbcConnection.setRemarksReporting(boolean) [diffDatabaseToChangeLog] seen table CLIENTES [diffDatabaseToChangeLog] seen table CREDITOS [diffDatabaseToChangeLog] seen table CUENTAS [diffDatabaseToChangeLog] seen table CuentasClientes [diffDatabaseToChangeLog] seen table MOVIMIENTOS_CUENTAS [diffDatabaseToChangeLog] seen table POLIZAS [diffDatabaseToChangeLog] seen table TAREAS_EN_CURSO [diffDatabaseToChangeLog] seen table TIPOS_CREDITOS [diffDatabaseToChangeLog] seen table TIPOS_POLIZAS [diffDatabaseToChangeLog] seen table TIPO_CUENTAS [diffDatabaseToChangeLog] seen table TIPO_MOVIMIENTOS [diffDatabaseToChangeLog] seen table TIPO_PERMISOS BUILD FAILED \ant\build.xml:815: java.lang.NullPointerException Caused by: java.lang.NullPointerException at liquibase.database.typeconversion.core.AbstractTypeConverter.getDataType( at liquibase.diff.DiffResult.addMissingColumnChanges( at liquibase.diff.DiffResult.printChangeLog( at liquibase.diff.DiffResult.printChangeLog( at liquibase.integration.ant.DiffDatabaseToChangeLogTask.outputDiff( at liquibase.integration.ant.DiffDatabaseTask.execute( ... 57 more

I’ll take a look.  Thanks!


The error is that the liquibase.jar included in from the direct link of download page is out of date.
The class liquibase.diff.DiffResult was updated at 28/10/09 in SVN when the .jar is from 8/10/09.
I think the error was solved including a not null condition statement.

Can someone compile a snapshot of the project?

You can get the current build from our buildserver:

Could you try that out? 


It works with the last library snapshot (liquibase-2.0-rc2.jar 11/17).


Thanks for checking it out.  Glad it worked