Setting liquibase.schemaName (or is it liquibaseSchemaName?) from the command line

I’m basically having the same issue found here. Nothing I do seems to alter the location liquibase looks for the DATABASECHANGELOG.

  1. .\liquibase.bat --defaultsFile=update.xml --logLevel=DEBUG --username="sys as sysdba" --password=secret status -DliquibaseSchemaName=TEST


  1. DEBUG 12/18/13 8:22 PM:liquibase: Connected to SYS@jdbc:oracle:thin:@db:1521:blah
  2. DEBUG 12/18/13 8:22 PM:liquibase: Setting auto commit to false from true
  3. DEBUG 12/18/13 8:22 PM:liquibase: Executing QUERY database command: SELECT MD5SUM FROM SYS.DATABASECHANGELOG WHERE MD5SUM IS NOT NULL

Clearly liquibase is looking in SYS, when I thought I was telling it to look in TEST.

Any help is greatly appreciated.

You should just have to use liquibaseSchemaName as a regular parameter without the -D. Like: