The system cannot find the path specified for Liquibase 4.2.3

When Liquibase 4.2.3 installed on a Windows 10 machine, it keeps saying “The system cannot find the path specified.”. I have updated the environment variables to the correct liquibase path and also have ensured that there is no unwanted space or anything of that. I also have JAVA_HOME set correctly

Not sure what else I am supposed to do here. Any help/pointers is appreciated.


Here is the environment variables screen shot:

Hi @arjunvenkatesh,

That seems odd. Here are the docs on installing on Windows: Install Liquibase on Windows
And docs on troubleshooting installation: Installation Troubleshooting

Is that screenshot your system’s PATH? Is liquibase.exe in C:\dev\liquibase?


@PJatLiquibase , Thanks you for your reply.
I downloaded the Liquibase installer liquibase-windows-x64-installer-4.23.0 from the Liquibase GitHub releases page (Releases · liquibase/liquibase · GitHub). Once the installation completes successfully and open the folder where liquibase is installed, I don’t see liquibase.exe there however I see “liquibase.bat”. I even downloaded the zip file and once I extract it, I don’t see a liquibase.exe.
At this point, I am not really sure if I am missing something here or the software packages is missing the exe file

Sorry @arjunvenkatesh, my mistake. It’s just liquibase, not liquibase.exe.

If you go into the install directory

cd C:\dev\liquibase
liquibase --version

Does that work?


That doesn’t work either. Still throws the same error.


Hi @arjunvenkatesh,

Well, it looks like liquibase is not in your path. That’s strange. You could try c:\dev\liquibase\liquibase --version and see if that works.

If not, I would try starting over from scratch. This is another good guide to help with path issues: Tutorial for Beginners | Using the Liquibase Installer |


@PJatLiquibase , thank you for your suggesstion, however running c:\dev\liquyibase\liquibase --version just runs another shell and it exits in less than millisecond.

I have tried installing fresh about 5-6 times so far and it the same thing. Even tried downloading the zip and extracting it, still the same issue.

As far as the documentation link that you shared, in the windows section it mentions Liquibase-Version#-bin , the bin folder is not there at all in the installed path. So I am not sure what should be done there.