Unable to generate liquibase script from the hive internal table

I am trying to execute a liquibase script to create a table in a hive database.
Getting error
errorMessage:Error while compiling statement: FAILED: SemanticException [Error 10099]: DATETIME type isn’t supported yet. Please use DATE or TIMESTAMP instead), Query: CREATE TABLE DATABASECHANGELOGLOCK (ID INT NOT NULL, LOCKED BOOLEAN NOT NULL, LOCKGRANTED datetime, LOCKEDBY VARCHAR(255), CONSTRAINT PK_DATABASECHANGELOGLOCK PRIMARY KEY (ID)).
Can anyone help me out?
Seems the internal tables of liquibase are attempting to use an invalid datatype.

I tried to create DATABASECHANGELOGLOCK and DATABASECHANGELOG manually (replacing with hive valid datatype).
Nonetheless, it tries to recreate those tables and fails with the same error.

Hive version is 3.1.3000. and the liquibase version is 4.14.0

Hi @Neesha.Rani - Welcome to the Liquibase Community!

This needs to be reported as an issue on our GitHub board. Here’s a link to the process: How to Report Liquibase Issues and Bugs | Liquibase.org