Unexpected error running Liquibase: Unable to read file

Hi all, I am really new to liquibase, I hope that someone can point me to the right direction.
I downloaded liquibase rev 4.12, zipped files on a win 2012 R2 server, I want to run it as a portable to make practice and test.
I have a Postgresql 10 DB with 7 schemas and a lot of tables. My aim is to take an ‘initial snapshot’ of the db, so I am running liquibase from CLI (dos shell) to generate first changelog (sql format). Command generate-changelog of DB structure ran without problems, the changelog file was all right, as far as I can see. DiffTypes were: tables,views,columns,indexes,foreignkeys,primarykeys,uniqueconstraints.
When I try to generate-changelog only for data (DiffTypes=data), instead, liquibase runs, writes csv data files (one for table, correctly) but at the end it shows the message ‘Unexpected error running Liquibase: Unable to read file [fullpathofmyfile.csv]’.

Here is my command line:
liquibase --changeLogFile=C:/Backup/liquibase/db/mydb/data/mydb.changelog-data.postgresql.sql --url=“jdbc:postgresql://[myserver]:5432/[mydb]” --username=[myusername] --password=[mypassword] --includeSchema=true --schemas=[myschemas] --overwriteOutputFile=true --log-level=INFO --logFile=C:/10_Logs/liquibase/lqb_mydb.log --diffTypes=data --dataOutputDirectory=C:/Backup/liquibase/db/mydb/data generate-changelog

What am I missing? I can’t understand.

Things noted / checked:

  • my user has all grants on DB objects;
  • the changelog file C:/Backup/liquibase/db/mydb/data/mydb.changelog-data.postgresql.sql is created but is empty;
  • fullpathofmyfile.csv exists and contains data, as expected;
  • my user has full read / write permissions on destination folder. Maybe liquibase needs other permissions on filesystem or maybe have to run with admin privileges?;
  • in the log file the message is always about the last csv data file written;
  • i tried on other DBs, smaller in size, have same error;
  • java version = 1.8.0_333

Thanks in advance
-------- cut from log file -------
SEVERE [liquibase.integration] Unable to read file C:/Backup/liquibase/db/mydb/data/myfile.csv
liquibase.exception.CommandExecutionException: liquibase.exception.LiquibaseException: Unexpected error running Liquibase: java.lang.RuntimeException: java.lang.RuntimeException: liquibase.exception.UnexpectedLiquibaseException: Unable to read file C:/Backup/liquibase/db/mydb/data/myfile.csv
at liquibase.command.CommandScope.execute(CommandScope.java:162)
at liquibase.integration.commandline.CommandRunner.call(CommandRunner.java:51)
at liquibase.integration.commandline.CommandRunner.call(CommandRunner.java:21)
at picocli.CommandLine.executeUserObject(CommandLine.java:1953)
at picocli.CommandLine.access$1300(CommandLine.java:145)
at picocli.CommandLine$RunLast.executeUserObjectOfLastSubcommandWithSameParent(CommandLine.java:2358)
at picocli.CommandLine$RunLast.handle(CommandLine.java:2352)
at picocli.CommandLine$RunLast.handle(CommandLine.java:2314)
at picocli.CommandLine$AbstractParseResultHandler.execute(CommandLine.java:2179)
at picocli.CommandLine$RunLast.execute(CommandLine.java:2316)
at picocli.CommandLine.execute(CommandLine.java:2078)
at liquibase.integration.commandline.LiquibaseCommandLine.lambda$execute$1(LiquibaseCommandLine.java:336)
at liquibase.Scope.child(Scope.java:189)
at liquibase.Scope.child(Scope.java:165)
at liquibase.integration.commandline.LiquibaseCommandLine.execute(LiquibaseCommandLine.java:301)
at liquibase.integration.commandline.LiquibaseCommandLine.main(LiquibaseCommandLine.java:90)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at liquibase.integration.commandline.LiquibaseLauncher.main(LiquibaseLauncher.java:91)

-------- end cut from log file -------

Hi, just an update…
the problem is the --dataOutputDirectory=C:/Backup/liquibase/db/mydb/data parameter.
If I delete it from command, liquibase runs successfully and changeLogFile contains all the sql insert.