Validation Failed without any changes


We have encountered problem with checksums. We have 3 environments: TEST, ACC and PROD.
Everything was working fine till today where we encounter such error:

… (CUT) …
Nothing has changed in code. Files are the same as weeks before. And the most important thing:
DATABASECHANGELOG table has exactly the same MD5 checksum in TEST, ACC and PROD databases and 

liquibase:updateSQL -PACC
liquibase:status -PACC

have problem on ACC and PROD but works fine for TEST environment.
What might cause a problem here ?
(I know I can solve this by liquibase:clearCheckSums but I would like to know the reason before hitting PROD db).

I have found solution myself :wink:

We had no definition of liquibase-maven-plugin so maven automatically pulled version of liquibase 3.6.0 (update in maven was done yesterday 05.04.2018)

and it looks like there was major change of checksum algorithm.

When I used 


problem was solved.

And the most magic thing is that when we executed 

Problem was solved.

We have separate user which has read access to:



but those tables are not in default schema. 

We had configuration for schema but it’s property was externalized to property file like this in pom.xml in section :


And was not set correctly.

I have moved config directly to profile:





No it works fine.

Thanks for reply.

Yes, working on rolling out 3.6.0, thanks for the bug reports.

There was a change in the checksum algorithm that made us have to update the version from 7 to 8. The update commands will handle that upgrade for you automatically, but status can’t because it doesn’t change the database, it just reads what is there. I should look at making it less error-y, though.

UpdateSQL should only require read access. What exception/error are you getting?


Good, thanks for letting me know.