Why is escape processing disabled ?

Hi all,

While finalizing my plugin to support Teradata database, I noticed that in JDBCExecutor, “Escape processing” is disabled.
This prevent us from using jdbc escapes for date/datetime/time literals.
What’s the reason for this ?


It is due to http://liquibase.org/forum/index.php?topic=796.  You should be able to use the valueDate attributes and liquibase should handle date formatting correctly.

Otherwise it may be worth adding the escape processing back in.  What all does it do?


JDBC escape sequence are very useful to put date/timestamp values in a standard way. It allows you to write date values in SQL statements without bothering with the particular date format of DBMS.
See the JDBC documentation : http://download.oracle.com/javase/1.4.2/docs/guide/jdbc/getstart/statement.html#999472

Why I would suggest is leaving escape processing enabled by default and adding a parameter to disable it for a particular SQL statement.

I committed a change to only enable the escapeProcessing for statements with ?'s in them (should be little to none)