A bug in generate-changelog and applying it to fresh database: ERROR: relation

I have a production database.
I generated change log from the schema “audit” from this database:

liquibase generate-changeLog --changelog-file=dev.sql --overwrite-output-file=true --include-schema=true --schemas=audit

Result file can be found here: dev.sql · GitHub

Then I created empty database, manually created there schema “audit” and ran:

liquibase update-sql --changelog-file=dev.sql

which showed me no errors:

Liquibase command 'update-sql' was executed successfully.

But when I ran actually update then I receive following error:

Unexpected error running Liquibase: Migration failed for changeset dev.sql::1702472324189-4::lightsaber:
     Reason: liquibase.exception.DatabaseException: ERROR: relation "core.ausschlusszeit_allgemein" does not exist
  Position: 337 [Failed SQL: (0) CREATE VIEW "audit"."tabellen_stats_core" AS SELECT combined_data.name,

is it a bug or what?
Full error here: gist:9a9cdd2f3a1d673fc5d6fea3db66aa0e · GitHub

Looks like the problem related to a view which related on another schema “core” which is not yet created. When I generate-changelog for all schemas which are important to me, then i get the same error, since sql statements for creating views often referred to the schemas which are created later in changelog file.

Why generate-changelog works that weird?

And how can I run generate-changelog correctly for all schemas in DB?
Or should I manually find out the correct order in which views should be created so their relations between schemas are also created in correct order.

But I thought the generate-changelog can help me to avoid such headache.