/* comments cause liquibase to skip lines

i have some procedure that have c style comments that start and end with /*

im using the tag inside a master change set to include files

and in a few scripts, i have it look like this

say for test.sql

  1. /* 
  2.   test.sql
  3. */
  4. insert into table x (x , b ,c);

in this case, when i run liquibase with java -jar i get a null pointer exception

and in another case i have a package body thats something like

  1. create or replace package
  3. /* comments
  4. */
  6. /*more comments
  7. */

this actually skips the XXX in the middle and at the end result when i use oracleSQLDeveloper, and view the package code, the procedure in between the comments are not there

i played around with it a bit more and it appears to be a problem when the ending comment doesn’t end at the beginning of a line

so it should be a straight forward fix…i hope

my script to a more accurate picture looks like 

  1. create package
  2. fuction A
  3. --
  4. function B
  5. /*--
  6. fuction C
  7. --*/
  8. function D
  9. /*--
  10. function F
  11. --
  12. */

function D would get skipped

but when i moved the comment directly above it to

  1. function C */
  2. --
  3. function D

it worked fine and didnt skip the function