Error: Driver class was not specified and could not be determined from the url (jdbc:databricks:

I am new to liquibase and am trying to use liquibase for Databricks Unity Catalog.
I am following this documentation: Databricks - contribute.liquibase.com
I ran the “liquibase --version” command and verified that I can see the drivers. But in the test connection part when I run the liquibase status command I get this error
“ERROR: Exception Primary Reason: Driver class was not specified and could not be determined from the url (jdbc:databricks://…”.
I tried directly mentioning driver and classpath but couldn’t resolve it.

Hi @Pemba,

Did you down load the Databricks JDBC driver and Liquibase Databricks extension jars and placed them in your <LIQUIBASE_HOME>/lib directory? Can you please also share your properties file? Are you running commands using CLI or MVN?

Thanks,
Daniel.

I am using the CLI. I have downloaded the libraries and added to the lib directory. I can see them when I run the liquibase --version command.

  • lib\databricks-jdbc.jar: databricks-jdbc UNKNOWN
  • lib\DatabricksJDBC42.jar: DatabricksJDBC42 UNKNOWN

As for the properties file, it pretty much just contains
url:jdbc:databricks://<your_workspace_host_name>:443/default;transportMode=http;ssl=1;AuthMech=3;httpPath=/sql/1.0/warehouses/<your_warehouse_id>;ConnCatalog=<your_catalog>;ConnSchema=<your_schema>;
username: token
password: <dbx_token>

I’ll check on Monday with someone from the team and let you know.

Thanks,
Daniel.

I’ve successfully using databricks for a while. There is also a java_opts requirement if you are running on linux. See 4 here:

Hey @Pemba,

Can you please download https://mvnrepository.com/artifact/org.liquibase.ext/liquibase-databricks/1.1.3, place it in your LIQUIBASE_HOME directory and try again? I think you probably don’t need lib\DatabricksJDBC42.jar: DatabricksJDBC42 and this is not working because you still need liquibase-databricks. Could you please try that and let us know?

Thanks,
Daniel.