Escape changeset property during update command

Hi all,

I would like to apply a changeset that contains a template message, e.g.


I would like to resolve variable using the web application but, unfortunately, this variable is resolved by liquibase during migration.

I saw in the liquibase source code that there is a variable that should do the trick


supportPropertyEscaping (alias enableEscaping), using it and escaping like ${} should works.


I tried to configure the supportPropertyEscaping property using file and using the -D approach, but nothing happens. I didn’t found any resource on internet.

Do you have any suggestions?

I run the tool using the CLI

Thank you


I forgot to mention that changelog are written in xml files and that sql is written inside the sql element.

Ok I found a solution.

In order to override the configuration I can define/override JAVA_OPTS env variable.
export JAVA_OPTS="$JAVA_OPTS -Dliquibase.enableEscaping=true"

I’m wondering if there are other ways to do the same with the CLI.