I'm getting this error InvocationTargetException: liquibase/servicelocator/PackageScanClassResolver: liquibase.servicelocator.PackageScanClassResolver after update liquibase from 3.5.6 to 4.8.0

I’m getting this error InvocationTargetException: liquibase/servicelocator/PackageScanClassResolver: liquibase.servicelocator.PackageScanClassResolver after update liquibase from 3.5.6 to 4.8.0.

My spring version is too old 1.4.0.RELEASE and I think that could be related with that.
Do you know if there is some way to solve this without updating my spring version?

Thanks in advance!

Since Spring Boot is currently in version 3.0.0 I think you’re probably going to need to update to at least version 2.7, as version 1.4.0 has been out of support for at least 3-4 years according to their site, and it’s generally not recommended to run EOL software for security reasons if nothing else.