Issue with liquibase cassandra - living non-daemon threads

I’m using liquibase directly from java to create objects in database. For other types of database it works well, but for cassandra - program never ends because of number of living non-daemon threads. Close connection did not help.
please check issue at
project to reproduce the issue at

Hi @shaloms,

We tried this out, we were able to run it in the Docker container as well. We did not come across any issues. May I know if you are able to run this scenario without using maven?

Before that, can you confirm is you are using liquibase-cassandra-4.1.1.jar ? You can find this Liquibase extension for Cassandra here: Releases · liquibase/liquibase-cassandra (

Hi @aditi !
I’m using dependency on liquibase-cassandra-4.4.3 (as you can see in pom.xml of my project)

Have you tried to run my project to reproduce the issue? GitHub - Jenya95/liquibase-cassandra-issue: This project was created to reproduce the issue that happens with liquibase-cassandra when non daemon threads prevent jvm to stop. I prepared good readme with steps how to reproduce it. Issue reproduces both with and without maven. You can run main method with every tool that you like.

Point is that I don’t use liquibase as separate cli tool with its jar, but as dependency and I want to run migration directly from code using method Liquibase#update(Contexts contexts, LabelExpression labelExpression)