OOM Exception, while data export using maven plugin

I am getting an exception while exporting the data from Oracle database using Liquibase.

I have used below maven command

mvn -e -X liquibase:generateChangeLog -Dliquibase.diffTypes=data -DargLine= "-Xms10G -XmX 20G -XX:-UseGCOverheadLimit"

last line I can see in the log before failing is,

[DEBUG] Executing with the ‘jdbc’ executor

When I checked the same in Java Visual VM, I found that liquibase.change.ColumnConfig class is consuming 80% of space, this is more likely a memory leakage issue.

On top of this when I checked the java memory space, I can see Old Gen space is utilised 100% and it never goes down after 50 mins of execution.

I would like to know is there a way to export a data for few specific table, if so please help with the maven command. I tried out below, but it didn’t worked out for me.

mvn -e -X liquibase:generateChangeLog -Dliquibase.diffTypes=data,table -Dliquibase.includeObjects=“table:myTable” -DargLine= "-Xms10G -XmX 20G -XX:-UseGCOverheadLimit"

The version of liquibase I am using is 4.2.0

Any help is highly appreciated…

Hi @AR036 ,

I tried the Liquibase CLI command as follows (I tried it with postgres DB, should not differ much for Oracle though):

liquibase --changeLogFile=dbchangelog.xml --url=jdbc:postgresql://localhost:5432/mydb --username=user --password=pass --includeSchema=true --schemas=my_schema --diffTypes=data,table --includeObjects=tablename generateChangeLog

It worked for me resulting out the corresponding changelog with DDL and DML changesets.

Please note if my table is in public schema then I do not need provide the includeSchema and schema attributes to this command and it works well without them.

Could you please try executing your second command with additional parameters for includeSchema and/or schemas?

If these parameters turns out to be incorrect for Maven execution, please find a list of attributes here.

Rakhi Agrawal

Hi Rakhi,

Tried, but no luck…
Is order of data and table matters? I guess main cause is memory leakage.

Even data from single table is not coming.