Liquibase 2.1.0 does not generate unique constraints for Postgresql

Liquibase 2.1.0, Postgresql 8.4, generateChangeLog command does not generate unique constrains into the XML file. Apparently I have the unique constrains in the database, but there is no such information in the generated file.

I am using the following command:

C:\Users\lukast\Desktop\liquibase-2.0.1-bin>liquibase --driver=org.postgresql.Driver --classpath=postgresql-8.4-701.jdbc4.jar --url=“jdbc:postgresql://localhos
:5432/db” --username= --password= --changeLogFile= --defaultSchemaName= --diffTypes=“tables, columns, views, primaryKeys, indexes, fo
eignKeys, data” --logLevel=debug --databaseClass=liquibase.database.core.PostgresDatabase generateChangeLog

The only information in the generated file about the column with the unique constraint from the database is:


Am I doing something wrong or is it 2.1.0 BUG ?
Is there any workaround ? Maybe it worked in older versions of liquibase ?
Thanks in advance for help.

I don’t think it is something that worked prior to 2.0.1.  The generateChangelog command currently doesn’t know to look for unique constraints since there is not an easy way to get that information in a cross-database manner.

Adding support for better database metadata access will be a focus for the next major version of liquibase (2.1)