Liquibase 3.6 XSD 403 error

This is my changelog

I am getting the following error:
Caused by: java.io.IOException: Server returned HTTP response code: 403 for URL: http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-3.6.xsd

If I point to 3.5.xsd, it works for me. Is there anyway that you have quick fix?

Hi,

I also have same issue today.
The XSD is using over 1 year but today suddenly failed.
Does have any changes on the XSD today?

LiquibaseAutoConfiguration$LiquibaseConfiguration.class]: Invocation of init method failed; nested exception is liquibase.exception.ChangeLogParseException: Error parsing line 5 column 70 of classpath:/db/changelog/changelog_original.xml: schema_reference.4: Failed to read schema document ‘http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-3.8.xsd’,

We have the same error since few hour. We update to 4.6.2 (latest) and the problem disapear.
On maven repo, this version doesn’t have the CVE-2021-23463 vulnérability…

On 4.6.2, the spring configuration work’s and the liquibase::diff goal work to !

I don’t know what is the difference on the online xsd and how this latest version get this xsd online… i hope that is a misconfiguration and not to force to migrate to the latest version… No communication on the website about this.

Sorry for the problems.

The is is that a “require https” setting somehow got enabled for those XSD urls. We’re shifting our website hosting provider and despite the fact that we explicitly tested for this requirement on staging, something seems different in their new production settings. We’re actively working with them to resolve the problem.

In general, Liquibase should read the xsd files bundled in the jar rather than try to download them but there have been a few versions over the years which had a bug that caused them to pull them from the network.

Upgrading to the current 4.6.2 version will address it from whatever versions have the “download the xsd” bug. Switching the XSD URL in your file to https instead of http will work too. Otherwise, we should hopefully have the redirecting issue fixed on our our side soon.

Nathan

Using maven plugin 3.6.3 the opposite is true,
switching the XSD URL in xml from https to http solves the problem (currently).
working url: “http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-3.6.xsd
Maybe because it is gathered from jars if not https?

The issue has been resolved. We have fixed the website 403/301 issues.

1 Like

Hi Mike, for 4.1 still occurs
Caused by: java.io.IOException: Server returned HTTP response code: 403 for URL: http://www.liquibase.org/xml/ns/dbchangelog/dbchangelog-4.1.xsd

1 Like

HI @mitro . Try again, we just fixed it a few minutes ago.

1 Like

its ok now. Thank you