Liquibase Connection to Ms SQL DB with Windows authentication

Hello Team,

I am using Liquibase 4.4.3 on Linux box.
my requirement is i need to connect to MS SQL DB with Windows authentication.
Sql Driver Version is sqljdbc4-4.0.jar also using sqljdbc_auth.dll.
also using integratedSecurity in DB URL.

Error message is: Driver is not configured for integrated authentication.

liquibase properties is like:
url: jdbc:sqlserver:0.0.0.0:1234;databaseName=DB1;integratedSecurity=true
username: username
password: password
classpath: sqljdbc4-4.0.jar

Please advise.

Thanks
Lalit KHATRI

Hi @lalitkhatri

I’m not familier with MS SQL, but from the error it seems to be some general issue and not related to Liquibase.

Could you please check this SO post and try out all suggested options in the comments.

Thanks!
Rakhi Agrawal

Thank you for your reply Rakhi, i managed to fixed that issue, that was some firewall issue.
but I am facing another error now.

in change log, i have defined my sql file path,
liquibase is always failing to find sql file.
files are in git and present in my jenkins workspace, still liquibase fail to find them.

Error message is:
Unexpected error running Liquibase: java.io.IOException: The file config/test/file.sql was not found in
/java8/…

Specifying files by absolute path was removed in Liquibase 4.0. Please use a relative path or add ‘/’ to the classpath parameter.

I am using v4.4.3, i tried all, relative path, absolute path, but doesnt work.

Please advise.

Thanks
Lalit

Hi @lalitkhatri

Great you could get the earlier issue fix.

Regarding the file not found issue, could you please share the changelog you have been using and also the console output with log level set to “DEBUG”.

Thanks,
Rakhi Agrawal

Haven’t used this liquibase version. But have you tried using escape characters? Example // instead of /.

And the path should be relative to your change-log file.

If issue still persists, please share your -

  • Changelog File

  • directory structure

  • the exact liquibase command being run.

Thank you for your reply @rd18 and @rakhi.
PFA details.

error message is: it cant find the sql file defined in changelog_0.1.xml.

i tried using:
./config/…
/config/…

nothing works

Hello, can advise please ?

ok, i fixed it, all good now.