Liquibase --help takes 40 seconds to run

I installed LB 4.25 and trying to run it. It takes 40 seconds for any commands, even without connecting to any databases just trying to get help.

If I enable FINE log level, I can see in logs :

[2024-01-03 09:21:22] FINE [liquibase.integration] Performance monitoring disabled
[2024-01-03 09:22:03] INFO [liquibase.integration] Starting command execution.

I tried to enable monitor performance, but I can’t find anything obvious in JMC.
I can see that set if calls repeated many times within those 40 seconds, but not sure if it’s JFR itself or liquibase does :

Does Liquibase internally make any calls to external hosts/sites?
I have laptop behind firewalls, with limited access to the internet, so if it does - it would explain this delay. but which host it tries to reach to ? and how to disable this behavior ?

I remember in previous versions there was a parameter like liquibase.hub.mode - but I can’t find it in doco for current version…

As I don’t even specifiy changelog file, not sure if it’s about XSD file.

PS. versions 4.3.5 and 4.13.0 works fine on this laptop.
PPS. the same liquibase version on my home laptop (both Macs, but different version of MacOS) without any limitations - works fine.

I have narrowed down the issue - it was introduced in 4.21.0 :

Wed Jan 03 10:54:31 liquibase > time 4.20.0/liquibase --version 2>&1 | tail -3

Liquibase Version: 4.20.0
Liquibase Open Source 4.20.0 by Liquibase

real	0m5.935s
user	0m1.680s
sys	0m0.128s
Wed Jan 03 10:54:40 liquibase > time 4.21.0/liquibase --version 2>&1 | tail -3

Liquibase Version: 4.21.0
Liquibase Open Source 4.21.0 by Liquibase

real	0m41.080s
user	0m1.710s
sys	0m0.136s

I’d recommend opening a Github issue: