Liquibase runner - Jenkins pipeline

Hi, I’m trying to invoke liquibaseUpdate from jenkins pipelines.
I’ve tried both scripted and declarative ones with no success.
I always end up with the following error message

java.lang.NoSuchMethodError: No such DSL method ‘liquibaseUpdate’ found among steps [archive, …

Any idea?
Could you please provide a working example of a complete pipeline?

This is similar to what discussed here, but I’m not looking for a workaround such as calling liquibase through the mvn plugin or from shell… especially cause I’d like to check whether

Any evaluated changesets are listed on the build’s summary page, as well as details about each changeset

as claimed at liquibase-runner-plugin’s github readme (i.e. the liquibase update works for free style jobs but I can’t see any evaluated changesets listed on the build’s summary page).

I confirm the error message lists all methods available for the DSL, and I can’t see any Liquibase related one.
The pipeline syntax generator doesn’t show any liquibase related method… it seems they are not registered.
Please also note the jenkins pipeline steps doc don’t show the plain DSL methods:

Liquibase Runner
  step([$class: 'DropAllBuilder']): Liquibase: Drop everything in database
  step([$class: 'RawCliBuilder']): Liquibase: CLI Command
  step([$class: 'RollbackBuilder']): Liquibase: Roll Back Changes
  step([$class: 'TagBuilder']): Liquibase: Tag Database
  step([$class: 'UpdateBuilder']): Liquibase: Update Database

I’ve tested it on a fresh Jenkins 2.277.4 with Liquibase Runner Plugin 1.4.10

Please also note I’ve commented to an issue opened some months ago.

Hi @davide.cavestro ,

Please help us understand the process you are following. Can you tell me what commands are you running to get the desired result?

@NathanVoxland @MikeOlivas This issue is out of my knowledge domain. Would you look into this issue?


Hi @aditi I essentially tried liquibase-runner-plugin/ at master · jenkinsci/liquibase-runner-plugin · GitHub on a fresh Jenkins docker instance.
I am experiencing cannot use in pipeline · Issue #31 · jenkinsci/liquibase-runner-plugin · GitHub