no long blob via liquibase?

Hi guys,

searching the web and the LiquiBase code it appears to me nobody ever struggled getting longblob via LiquiBase even as it is not supported directly.
When using hsql I have no problem saving images via my DAO but when switching to MySQL, blob is not big enough anymore.
What would be the standard way to get a sufficiently large blob with LiquiBase?
My “workaround” now is to have blob be replaced by mediumblob within a modifySql-block:


thanx in advance,


P.S.: Also a pointer to String.replaceAll, which essentially is what regExpReplace does would have been handy)

If liquibase doesn’t understand a data type, it will simply pass it along verbatim to the database, expecting you know what you are talking about.  What you are doing should work.  Another option would be to use changeset parameters and define your datatypes as ${blob} and pass blob=blob for hsql and blob=mediumblob for mysql.  Starting with 2.0 (IIRC) you can specify those values for given databases at the top of your changelog file so you don’t have to pass them in.


thanx alot. as we want to be db-independent using longblob in liquibase code is not an option but good to know it works that way. else, we are looking forward to 2.0 :wink: