precondition problem mysql


I am having a problem with this changeset


    <createSequence incrementBy="1"

When I run this against MySQL database, it still tries to run. Is this a known bug.


It is working for me on 3.2.1. Can you try the newest version? (3.2.1 should be out later today or monday)


Just tried latest version, I am still getting the error.

liquibase: liquibase.statement.core.CreateSequenceStatement is not supported on mysql, but createSequence will still execute

SEVERE: null liquibase.exception.ValidationFailedException: Validation Failed:      1 changes have validation failures           createSequence is not supported on mysql, ./changelog.xml::1::author

Then execution of the xml stops processing. I am using MySQL 5.6.17

Is this caused by the fact that the docs say it is not supported for MySQL?

Yes, sequences are not supported by mysql which is causing the problem. Previous versions allowed it assuming you knew they wouldn’t get created but a better route is to add a dbms attribute to explicitly handle it.