XML changelog does not generate schema in Oracle db


Looking for some help with Liquibase issue. Appreciate any support.

I want to migrate schema from one Oracle db to another.
Log in via SQLcl to database1.
Generated changelog with genschema command:

<?xml version="1.0" encoding="UTF-8"?> 
  <include file="***.xml"/> 
  <include file="***.xml"/> 

It includes all schema objects except tablespaces.

Eg. XML changeset for the table looks like:

	<changeSet id="****" author="(***)-Generated" failOnError="false"    >
		<n0:createSxmlObject objectName="TABLE_NAME" objectType="TABLE" ownerName="OWNER_NAME"   >
  <TABLE xmlns="http://xmlns.oracle.com/ku" version="1.0">

I create tablespace and schema in database2 manually.

Then with pipeline connected to database2 and liq in container, I run:
liquibase update --changelog-file=controller.xml

created in schema successfully.

But content of the schema is empty - no sequences, tables, triggers etc.

I tried SQL versions of changesets, but there is a total mess and issues with delimiter.

Hi, unfortunately the logic for how to generate those changesets (including what to do with tablespace information) and how they convert to SQL is in the SQLcl product which we don’t have access to.

So that question is best asked on the oracle support forums, they will be able to help you more.