Controller.xml file not generated with genschema command

Hi all,
I’m using an Oracle database with a LOT of objects.
I started with a very simple command:
liquibase genschema -split
Everything is running without errors until the procedure is generating the changeLog file

[Method loadCaptureTable]:                       41180 ms
[Method processCaptureTable]:                  1108810 ms
[Method sortCaptureTable]:                        3787 ms
[Method cleanupCaptureTable]:                     6111 ms
[Method writeChangeLogs]:
The following are objects that were not able to be parsed correctly.
This means they will not be sorted according to any object dependencies.

                       18750 ms

The controller.xml is not generated: is this a bug or expected behavior?

1 Like

Welcome, @marco_fabbri!

I’m going to edit your post to try and reflect the parts of it that are code, commands, or output. Did you directly copy and paste this from your command line? What version of Liquibase are you using?

It looks like this was reported on the Oracle forum as a bug:

You can report it on our side as well: How to Report Liquibase Issues and Bugs |

Hi @marco_fabbri

Are you using Liquibase core gen schema functionality or Oracle SQLcl Liquibase genschema?

Based on your output (and presence of -split parameter), I suspect you are using the latter (SQLcl Liquibase genschema). You can check this if you run liquibase version (in the console). If you see an Extension Version row, it is as I think.
There are some differences between the two versions (as Oracle has it’s own logic layer over Liquibase-core). Just want to be sure we’re on the same page before trying to find a root cause of this.


1 Like

Hi @EduardUta, thank you for your answer.
Yes, we are using the Oracle Liquibase genschema: do you need additional information?

1 Like

Hi @tabbyfoo, we are using the Oracle version of Liquibase available in SQLcl (the latest available). And thank you for the Oracle community link but this is not the error we’ve got: maybe we should activate the debug mode but I’m not sure how to do it.

1 Like

@marco_fabbri can’t figure out a root cause for this; indeed, it looks like it is related to the bug that Tabby was mentioning above.


1 Like