Can't connect to Oracle DB with a special character in pwd

Yes, i’m running from the command line. I did try single quotes, double quotes around the pwd, connection still fails if the pwd has special character. If it does not, it works ok. I’m running windows 7. per company security policy, the pwd needs to contain a special characters, and it becomes tricky.

The problem is with the windows command line. when running liquibase using .jar file, it works fine. :slight_smile:


Thanks for your help, Nathan.

Liquibase should just be passing it as it gets it to oracle. Are you running from the command prompt and need to quote the value so the shell doesn’t do strange things with it?


I can’t connect to Oracle DB using Liquibase using a user with pwd that has a special character. In this case “!” in the pwd. Using different account with regular pwd, it works ok.


I can’t seem to get around the special character. Any idea how to resolve it?


I have Oracle client: 11.2.0 and jdk1.7.0 installed on my machine.




You could try setting the password in a properties file and passing it with the parameter. Does that help?


I created to track the issue