Oracle Wallet

I have finally been able to make liquibase aware of oracle wallet. I am running Oracle 11.2. The whole command is in one line,but I am showing it in multiple lines for clarity:

 mvn -X -e liquibase:update
-Dliquibase.emptyPassword=false (I have tried true no luck)
-Dliquibase.username=USER
-Dliquibase.url=jdbc:oracle:thin:/@oracle1
-Ddriver=oracle.jdbc.OracleDriver
-Doracle.net.tns_admin=/apps01/oracle/client/network/admin
-Doracle.net.wallet_location=/apps01/oracle/wallet
-Dliquibase.changelogSchemaName=USER
-Dliquibase.changelogCatalogName=USER
-Dliquibase.contexts=oracle1,my-ticket

Caused by: java.sql.SQLException: ORA-01005: null password given; logon denied

.I am passing all arguments in the command instead of using the liquibase.properties file.

Why is liquibase not picking up the password for USER ?
Yes the entries for tnsname.ora, sqlnet.ora, wallet.ora are all correct, since when I type “sqlplus /@oracle1” it works

$ sqlplus /@oracle1

SQL*Plus: Release 11.2.0.1.0 Production on Fri Mar 31 14:40:25 2017

Copyright © 1982, 2009, Oracle.  All rights reserved.

Connected to:
Oracle Database 11g Enterprise Edition Release 11.2.0.4.0 - 64bit Production
With the Partitioning, Real Application Clusters, OLAP, Data Mining
and Real Application Testing options

SQL>

Any clues? Pointers?