Liquibase 3.X BUGS

Hi everyone!
Here is described BUG and it is not fixed in 3.X version. As described, data dump export into cvs-files works fine with liquibase-2.0.5 but fails in 3.X with error:
"Liquibase generateChangeLog Failed: org/yaml/snakeyaml/representer/Representer"

I’d tried different solutions - from CORE-1417, changed snakeyaml lib to 1.13 - everything was unsuccsessful. With the same config with 2.0.5 version everything was generated fine.

Please fix it ASAP - it is very useful feature for managing DB data.

Another inconvenient aaproach: or in my case doesn’t support relative paths ( i mean - relative to changelog it runs from inside ) - please fix it. is the existing ticket to add relativeToChangeLogFile to loadData and all, but it hasn’t been implemented yet, unfortunately. 

The snakeyaml requirement is new in 3.0 due to the support for yaml and json formats. As long as snakeyaml 1.12 or 1.13 is in your classpath, everything should work fine. Can you show how you are running liquibase? 


Hi, Nathan. And thanks you for quick response!
So, I’d tried to run data export to csv in such way:
- OS: CentOS 6.4 x64
- JVM:
java version "1.7.0_17"
Java™ SE Runtime Environment (build 1.7.0_17-b02)
Java HotSpot™ 64-Bit Server VM (build 23.7-b01, mixed mode)

- Liquibase: 3.0.5 -

~/Tools/liquibase-3.0.5 - liquibase (command-line) tool folder with:
java -classpath lib/snakeyaml-1.13.jar -jar liquibase.jar --classpath=lib/postgresql-9.2-1003.jdbc4.jar --dataOutputDirectory=csv generateChangeLog

#########all libs are present in lib/ folder, all configuration items are valid, try to run for exporting data. When use 2.0.5 with the same configuration - everything is OK.

If something is wrong from my inputs - please let me know. If not - …how it could be fixed? Because downgrade to 2.0.5 - is bad solution. We need Liquibase 3.0+ with its new features.

<Load(Update-)Data> issue is opened too - we need relative path to data CSV-files.

Please let me know if any updates appears.
Thanks a lot!


Apparently -jar and -cp are incompatible for Java. (see

You’ll have to run:


Since it is a change to the XSD it will be part of the 3.1 release at the earliest. I don’t have a timeframe for 3.1 yet, but hoping around the end of October.