Liquibase ' All host(s) tried for query failed' with Cassandra 4


Jars used:

  • CassandraJDBC42-2.0.4.jar (to establish jdbc connection)

  • liquibase-cassandra-4.16.1.jar (extension jar)

  • liquibase-core-4.6.1.jar (core liquibase jar)

All of the above was working properly with my Liquibase project with Cassandra 3.11.0, but once I upgraded to Cassandra 4.0.6 I started getting the connection issue:

Caused by: [Simba][CassandraJDBCDriver](500150) Error setting/closing connection: All host(s) tried for query failed (tried: xxxx:9042 (com.simba.cassandra.shaded.datastax.driver.core.exceptions.TransportException: [xxxx:9042] Channel has been closed)).

(I xxxx’d out my server and IP for my cluster)

On the Cassandra side of things I get the error in my log:

[WARN ] [epollEventLoopGroup-5-1] cluster_id=xxxx ip_address=xxxx - Unknown exception in client networking
io.netty.handler.codec.DecoderException: error:100000b8:SSL routines:OPENSSL_internal:NO_SHARED_CIPHER

I was able to test that my JDBC jar is able to connect to my Cassandra DB without any issue using my JDBC URL via Intellijj’s database GUI, so I don’t believe anything is wrong there. And all of my applications that speak with this Cassandra database work properly still as well, only my liquibase project is affected.

Any help would be great.

I get this issue by running:
java -jar jars/liquibase-core-4.6.1.jar --defaultsFile=liquibase/ status
But I get this same issue if I download Liquibase 4.17 and use the liquibase CLI

There have been a couple of reports of other issues with Cassandra and Liquibase recently. I don’t know if this is related or not, but you can open an issue in the liquibase-cassandra repo and hopefully someone can help fix it. GitHub - liquibase/liquibase-cassandra: Liquibase extension for Cassandra Support